table

UrlClickEvents

UrlClickEvents contains Safe Links click events from email messages, Teams, and Office 365 apps.

tablesCurrent

Relationships

Schema

FieldTypeDescriptionCopy
TimestampdatetimeDate and time when the user clicked the link.
UrlstringFull URL clicked by the user.
ActionTypestringType of click action or verdict event.
AccountUpnstringUser principal name of the account that clicked the URL.
WorkloadstringWorkload where the click originated.
NetworkMessageIdstringUnique identifier for the related email message when available.
ThreatTypesstringThreat verdict associated with the URL when available.
DetectionMethodsstringDetection technology used to identify the threat at click time.
IPAddressstringPublic IP address of the device from which the user clicked the link.
IsClickedThroughboolIndicates whether the user clicked through to the original URL from the Safe Links warning page.
UrlChainstringURLs present in the redirection chain, when applicable.
ReportIdstringUnique identifier for the click event.
AppNamestringName of the client application where the click occurred.
AppVersionstringVersion of the client application where the click occurred.
SourceIdstringUnique identifier for the source of the click.
TenantIdstringLog Analytics workspace ID.
TypestringName of the table.
SourceSystemstringType of agent the event was collected by.
TimeGenerateddatetimeDate and time when the user clicked the link; identical to Timestamp.

Sample KQL

Allowed or clicked-through risky links

Find Safe Links events where users reached or clicked through to a URL with a threat verdict.

kql
UrlClickEvents
| where Timestamp > ago(7d)
| where ThreatTypes != "" or ActionType has_any ("ClickAllowed", "ClickBlocked", "ClickThrough")
| summarize Clicks=count(), Users=dcount(AccountUpn) by Url, ActionType, ThreatTypes, IsClickedThrough
| order by Clicks desc