Map fields to tables and requirements.
Search a schema field and see every table containing it, plus the source product, required license, and API used to query it.
Common Security Pivot Fields
| Pivot | Fields to try | Use |
|---|---|---|
| Identity | AccountUpn, UserPrincipalName, Identity, InitiatingProcessAccountUpn | User investigation, sign-in pivots, mailbox activity |
| Endpoint | DeviceName, DeviceId, FileName, SHA256, InitiatingProcessFileName | Host timeline, file/process pivots, endpoint scoping |
| Network | RemoteIP, LocalIP, IPAddress, RemoteUrl, Url | IP/domain/URL pivots across endpoint and email telemetry |
| SenderFromAddress, RecipientEmailAddress, NetworkMessageId, InternetMessageId | Message trace, attachment, URL, and click correlation |
kql
let searchValue = "203.0.113.10";
union isfuzzy=true
DeviceNetworkEvents,
DeviceEvents,
EmailEvents,
EmailUrlInfo,
UrlClickEvents,
IdentityLogonEvents
| where tostring(pack_all()) has searchValue
| project Timestamp, Type, DeviceName, AccountUpn, SenderFromAddress, RecipientEmailAddress, RemoteIP, RemoteUrl, Url, NetworkMessageId
| order by Timestamp descQuery Examples Using Common Fields
| Field | Example | Catalog |
|---|---|---|
NetworkMessageId | Email to URL to click investigation | Open query |
AuthenticationDetails | Inbound email authentication summary | Open query |
ProcessCommandLine | Suspicious PowerShell launch review | Open query |
Identity | Intune policy change review | Open query |
RemoteIP | Threat indicator to endpoint network join | Open query |